Why can't I connect after latest the macOS v5.3.2.10 upgrade?

Follow

 

We identified an issue with the macOS application and it was fixed on June 4th, please download the latest version v5.3.2.11 and the issue will be solved:

https://static.perimeter81.com/apps/osx/Perimeter81.pkg

2 out of 2 found this helpful

Comments

0 comments

Please sign in to leave a comment.